Search This Blog

Tuesday, February 28, 2012

How to Convert Decimal 4-byte AS to AS-DOT+

AS-DOT+:
- Representation is based upon the existing 2-byte AS representation
- The full binary 4-byte AS number is split two words of 16 bits each
Notation:
<higher 2 bytes in decimal>.<lower 2 bytes in decimal>
For example: AS 65546 is represented as “1.10”
- Easy to read, however hard for regular expressions

Note: If the higher order 16 bits represent the value of a decimal zero, then the 4-byte AS can be represented in as the traditionally well known 2-Byte AS format

In order to convert decimal number into AS-DOT+ notation follow these steps:
1. Take the decimal number and divide it by 65536
2. Write down the number in the left side of the dot
3. Multiple 65536 in the result in section 2  
4. Subtract the decimal number by the result in section 3
5. The AS-DOT+ notation will be x.y where x is the result in section 2 and y is the result in section 4.

Example:
Let’s take AS 65539:
65539/65536=1.0000457763671875 (so x=1)
65539-(65536*1)=3 (so y=3)
AS number 65539 in AS-DOT+ notation is 1.3

Another example:
Let’s take AS 157600:
157600/65536=2.40478515625 (so x=2)
157600-(65536*2)=26528 (so y=26528)
AS number 157600 in AS-DOT+ notation is 2.26528

a calculator is available in the following link:  http://labs.spritelink.net/ascalc



Friday, February 24, 2012

RIP Auto-summary


Following my last post regarding route redistribution i found out that when i configure RIP with no auto-summary and with a specific network segment it will still keep advertise the network as major class and by that advertise other interfaces which i wasn’t interested to advertise.


Here is the topology i used:


i configured RIP on R4 as follow:

R4(config-router)#router rip
R4(config-router)#ver 2
R4(config-router)#no au
R4(config-router)#network 10.1.24.0

but when i looked on RIP database i found the following:

R4#sh ip rip database
10.0.0.0/8    auto-summary
10.1.12.0/24
    [1] via 10.1.24.2, 00:00:12, FastEthernet0/0
10.1.24.0/24    directly connected, FastEthernet0/0
10.1.34.0/24    directly connected, FastEthernet0/1
172.20.0.0/16    auto-summary
172.20.0.0/24
    [2] via 10.1.24.2, 00:00:12, FastEthernet0/0
192.168.10.0/24    auto-summary
192.168.10.1/32    redistributed
    [5] via 200.0.0.5, from 192.168.20.1,
192.168.20.0/24    auto-summary
192.168.20.1/32    redistributed
    [5] via 200.0.0.5, from 192.168.20.1,
<OUTPUT OMMITED>

note that R4 is also advertising network 10.1.34.0/24 which i didn’t configured, so i tough that i configured something wrong on RIP so i looked on the running-configuration:

R4#show running-config | s rip
redistribute rip subnets
router rip
version 2
redistribute ospf 1 metric 5
network 10.0.0.0
no auto-summary

so after looking around for an answer regarding this behavior i got a great explanation from Peter Paluch on Cisco Support Community:
The behavior you have observed is correct. Even though you configured each router with a particular network statement, the RIP configuration now contains only the network 10.0.0.0 statement - check your running-config. Cisco's RIP implementation always masks the address in the network command by the corresponding classful mask before entering it into running configuration. The roots of this behavior lie in RIPv1 and the behavior was not changed for RIPv2. This means that even if you configure each RIPv2 router using a particular subnet of the 10.0.0.0/8 range, the RIP on each router is running over all interfaces that lie in the 10.0.0.0/8 range. This is the reason why R3 advertises the 10.1.34.0/x network even though you have not explicitly added it to RIP. There is nothing you can do about it - in other words, Cisco's RIP implementation can not be configured to run only over a selected subnet of a classful network. The automatic summarization is not related to this behavior at all.

The auto-summary networks in the RIP database are always created by the RIP process. However, they are not advertised until the condition for their advertisement is met: a network from one particular classful network is going to be advertised out an interface that itself lies in a different classful network.

Redistribution Lab

here is the following scenario:
 
R1 is configured with RIPv2 and EIGRP AS100 while both Lo1 and Lo2 are advertised on both protocols, R5 advertise both loopbacks through OSPF to R4.

Note that RIP will advertise all connected interface by default, which i will explain in the next post.

R4 routing table is as follows:
R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     4.0.0.0/32 is subnetted, 1 subnets
C       4.4.4.4 is directly connected, Loopback0
C    200.0.0.0/24 is directly connected, FastEthernet1/0
     192.168.10.0/32 is subnetted, 1 subnets
O       192.168.10.1 [110/2] via 200.0.0.5, 00:02:32, FastEthernet1/0
     172.10.0.0/24 is subnetted, 1 subnets
D       172.10.0.0 [90/435200] via 10.1.34.3, 00:03:16, FastEthernet0/1
     172.20.0.0/24 is subnetted, 1 subnets
D       172.20.0.0 [90/435200] via 10.1.34.3, 00:03:16, FastEthernet0/1
     192.168.20.0/32 is subnetted, 1 subnets
O       192.168.20.1 [110/2] via 200.0.0.5, 00:02:33, FastEthernet1/0
     10.0.0.0/24 is subnetted, 4 subnets
D       10.1.13.0 [90/307200] via 10.1.34.3, 00:27:54, FastEthernet0/1
R       10.1.12.0 [120/1] via 10.1.24.2, 00:00:18, FastEthernet0/0
C       10.1.24.0 is directly connected, FastEthernet0/0
C       10.1.34.0 is directly connected, FastEthernet0/1

Note that R4 is learning networks 172.10.0.0/24 and 172.20.0.0/24 from R3 through EIGRP, due to lower AD of this protocol. So while redistributing RIP into OSPF, R5 is not learning these networks.

R5 routing table:
R5#        sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    200.0.0.0/24 is directly connected, FastEthernet0/0
     5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback0
C    192.168.10.0/24 is directly connected, Loopback1
C    192.168.20.0/24 is directly connected, Loopback2
     10.0.0.0/24 is subnetted, 3 subnets
O E2    10.1.12.0 [110/20] via 200.0.0.4, 00:00:16, FastEthernet0/0
O E2    10.1.24.0 [110/20] via 200.0.0.4, 00:00:16, FastEthernet0/0
O E2    10.1.34.0 [110/20] via 200.0.0.4, 00:00:16, FastEthernet0/0

In order to allow network 172.10.0.0/24 to be advertised to R5 I have configured a distribute-list on R1:
R1(config)#ip access-list standard NET172
R1(config-std-nacl)#deny 172.10.0.0 0.0.0.255
R1(config-std-nacl)#permit any
R1(config-router)#distribute-list NET172 out fastEthernet 0/1

And the result:
R5#        sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    200.0.0.0/24 is directly connected, FastEthernet0/0
     5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback0
C    192.168.10.0/24 is directly connected, Loopback1
     172.10.0.0/24 is subnetted, 1 subnets
O E2    172.10.0.0 [110/20] via 200.0.0.4, 00:00:13, FastEthernet0/0
C    192.168.20.0/24 is directly connected, Loopback2
     10.0.0.0/24 is subnetted, 3 subnets
O E2    10.1.12.0 [110/20] via 200.0.0.4, 00:09:04, FastEthernet0/0
O E2    10.1.24.0 [110/20] via 200.0.0.4, 00:09:05, FastEthernet0/0
O E2    10.1.34.0 [110/20] via 200.0.0.4, 00:09:05, FastEthernet0/0

But this will prevent from R3 to be a redundant path in case of failure in R2 path or to have load balance between these 2 networks, from R5 to R1 network 172.10.0.0/24 through R3, and from R5 to R1 network 172.20.0.0/24 through R2.

One way I found out to overcome this problem is to redistribute network 172.20.0.0/24 on R1 EIGRP, using a route-map, and by that to give this network an AD of 170 (EIGRP external)

R1(config)#route-map NET172 permit 10
R1(config-route-map)#match interface lo2
R1(config-route-map)#router eigrp 100
R1(config-router)#redistribute connected route-map NET172
R1(config-router)#no network 172.20.0.1 0.0.0.0

And the result on R5:
R5#        sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    200.0.0.0/24 is directly connected, FastEthernet0/0
     5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback0
C    192.168.10.0/24 is directly connected, Loopback1
     172.20.0.0/24 is subnetted, 1 subnets
O E2    172.20.0.0 [110/20] via 200.0.0.4, 00:00:01, FastEthernet0/0
C    192.168.20.0/24 is directly connected, Loopback2
     10.0.0.0/24 is subnetted, 3 subnets
O E2    10.1.12.0 [110/20] via 200.0.0.4, 00:19:57, FastEthernet0/0
O E2    10.1.24.0 [110/20] via 200.0.0.4, 00:19:58, FastEthernet0/0
O E2    10.1.34.0 [110/20] via 200.0.0.4, 00:19:58, FastEthernet0/0

Now let’s redistribute network 172.10.0.0/24 through EIGRP on R4:
R4(config-router)#router rip
R4(config-router)#redistribute ospf 1 metric 5
R4(config-router)#router eigrp 100
R4(config-router)#redistribute ospf 1 metric 100000 100 255 1 1500

Unlike OSPF which has a default metric seed of 20, in EIGRP and RIP we have to configure a metric else we will get an infinity metric.

RIP with no metric configured gets metric of 16 which in RIP equals to infinite:

 RIP with metric 5 configured:

Using traceroute we can verify that R5 is learning network 172.10.0.0/24 from R4 through R3 and network 172.20.0.0/24 from R4 through R2:
R5#traceroute 172.10.0.1

Type escape sequence to abort.
Tracing the route to 172.10.0.1

  1 200.0.0.4 52 msec 16 msec 20 msec
  2 10.1.34.3 24 msec 40 msec 20 msec
  3 10.1.13.1 56 msec *  92 msec
R5#traceroute 172.20.0.1

Type escape sequence to abort.
Tracing the route to 172.20.0.1

  1 200.0.0.4 36 msec 20 msec 20 msec
  2 10.1.24.2 52 msec 28 msec 20 msec
  3 10.1.12.1 76 msec *  64 msec

Now R1 is learning both networks 192.168.10.0/24 and 192.168.20.0/24 from R2 due to RIP preferred (lower) AD. If we would like split these 2 networks, one for each path, through a different router we will have to use different method, from the one that I use earlier with EIGRP, because RIP doesn’t differentiate between internal and external routes.

So I tried a few methods to manipulate these routes, which R4 learns from R5, and see how I can achieve the result where one route (192.168.10.0/24) is preferred through R3 and the other (192.168.20.0/24) preferred through R2, in perspective view from R1.

While trying to use the distance command on EIGRP I found the following post which helped me to understand why I didn’t succeeded:
If it is an internal route, you can change their AD , use the cmd "distance <AD> <source> <list>"
if it is an EIGRP external route you cannot do that per route, you can do this for all the external routes. Use the command "distance eigrp <internal_AD> <external_AD>"

Also note that the distance command is locally significant and it isn’t traversing along with the route updates between adjacent neighbors.

So the solution I came up with is to configure the distance command on R1 and increase the AD of learned route 192.168.10.0/24 through RIP:
R1(config)#access-list 10 permit 192.168.10.0 0.0.0.255
R1(config)#access-list 10 deny any                     
R1(config)#router rip                                 
R1(config-router)#distance 180 10.1.12.2 0.0.0.0 10    

Clearing the routing table (clear ip route *) and here is the result:
R1#sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
R    200.0.0.0/24 [120/6] via 10.1.12.2, 00:00:01, FastEthernet0/0
     192.168.10.0/32 is subnetted, 1 subnets
D EX    192.168.10.1 [170/332800] via 10.1.13.3, 00:00:01, FastEthernet0/1
     172.10.0.0/24 is subnetted, 1 subnets
C       172.10.0.0 is directly connected, Loopback1
     172.20.0.0/24 is subnetted, 1 subnets
C       172.20.0.0 is directly connected, Loopback2
     192.168.20.0/32 is subnetted, 1 subnets
R       192.168.20.1 [120/6] via 10.1.12.2, 00:00:03, FastEthernet0/0
     10.0.0.0/24 is subnetted, 4 subnets
C       10.1.13.0 is directly connected, FastEthernet0/1
C       10.1.12.0 is directly connected, FastEthernet0/0
R       10.1.24.0 [120/1] via 10.1.12.2, 00:00:03, FastEthernet0/0
D       10.1.34.0 [90/307200] via 10.1.13.3, 00:00:03, FastEthernet0/1

So finally we have R1 and R5, learns two different networks , each on different path.

Saturday, February 18, 2012

Separate companies - redundant topology


This one is real life scenario where two companies, which owns two Ethernet lines (50Mb each), want to get separate but keep load-balance, on regular basis, and redundant path in case of failure, for each one of them.

I will use the following topology:

Network setup:
      -          Each Ethernet line is provided with two separate VLAN’s from the service provider
      -          CPE1 represent the companies physical location, two LAN’s, one for each company 
             (Company 1-192.168.11.0/24 and Company 2-192.168.12.0/24)
      -          CPE2 represent some sort of data center where servers, firewalls and internet exit 
             located (Company 1-192.168.21.0/24 and Company 2-192.168.22.0/24)
      -          BGP is used as routing protocol (real customer demand) while I would prefer OSPF or  
            EIGRP which were much suitable for this topology.
      -     HSRP is used between CPE and routers for keeping the default route

I had to use  VRF lite in order to separate the routing tables for each company

After I finished configuring the interfaces, in their correct VRF, I started to configure the BGP and noticed that no neighbor had come up and I started to get the following messages:

*Mar  1 18:14:48.719: %BGP-4-NORTRID: BGP could not pick a router-id. Please configure manually.
And:

R4#sh ip bgp
% BGP cannot run because the router-id is not configured

After a little investigation I saw that the routers don’t have router-ID:

R4#sh ip bgp vpnv4 vrf CO1
% BGP cannot run because the router-id is not configured

BGP table version is 1, local router ID is 0.0.0.0
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:100 (default for vrf CO1)
*  10.1.34.0/24     0.0.0.0                  0         32768 i
*  192.168.21.0     10.1.34.254              0         32768 i


And this is my conclusion although I didn’t check it for sure so I may be wrong:
The routing process should take the highest IP (first loopbacks the interfaces) as the router-ID, in this situation he couldn’t use any IP because there were in VRF and not in the global routing table.

After configuring  a loopback interface is solved this problem.

the rest of this lab, along with configs and NET map, can be found in the following link:
http://www.4shared.com/rar/2NVMjzxb/CONFIG.html





Wednesday, February 15, 2012

Windows shutdown and restart through CLI

From time to time i need to restart or shutdown a virtual-machine through an RDP connection,
so i have created 2 shortcuts on my desktop using the following commands:

For restart the host:
shutdown -r -t 01

For shutdown the host:
shutdown -s -t 01

Where t is the time parameter in seconds,
for stopping this process use: shutdown -a 

this will work for Microsoft windows XP and 2000 and Win7.

Monday, February 13, 2012

Juniper/Cisco MPLS Layer-2 VPN configuration


Here is the following scenario:


The following post will explain how to configure an MPLS Layer-2 VPN, using single interface, to multiple far end interfaces, where both Juniper and Cisco routers are been used.

This is taken from a production network which I configured lately to one of our customers.

Topology setup:
       -          An MPLS network based on LDP/MPLS, IGP, BGP, MP-BGP
       -          AGG1 - An aggregation switch which terminate customer’s layer 2 connections
       -          3x PE routers (PE1 and PE2 are Juniper J6350 and PE3 is Cisco 7206VXR)
       -          Customer’s switches and CPE’s

Note that the interfaces, which connected from the switches, to the MPLS Layer-2 VPN ingress interface, should be in trunk mode.

The following configuration is referring to PE routers:

PE1 Configuration (Juniper router)
      1.       Make sure router’s loopback is configured under mpls and ldp protocols else configure it:
root@PE1# set protocols mpls interface lo0.0
root@PE1# set protocols ldp interface lo0.0

      2.       Configure the physical ingress router interface for 802.1q tagging for a cross-connect:
root@PE1# set interfaces ge-0/0/2 vlan-tagging
root@PE1# set interfaces ge-0/0/2 encapsulation vlan-ccc

      3.       Configure the appropriate interfaces as units under the physical interface:
root@PE1# set interfaces ge-0/0/2 unit 2900 encapsulation vlan-ccc vlan-id 2900
root@PE1# set interfaces ge-0/0/2 unit 2077 encapsulation vlan-ccc vlan-id 2077

      4.       Now configure the Layer-2 circuit under protocols:
[edit protocols]
root@PE1# set l2circuit neighbor 155.1.1.2 interface ge-0/0/2.2900 virtual-circuit-id 2900
root@PE1# set l2circuit neighbor 155.1.1.2 interface ge-0/0/2.2900 no-control-word
root@PE1# set l2circuit neighbor 155.1.1.2 interface ge-0/0/2.2900 encapsulation-type ethernet-vlan
root@PE1# set l2circuit neighbor 155.1.1.2 interface ge-0/0/2.2900 mtu 1500 
root@PE1# set l2circuit neighbor 155.1.1.3 interface ge-0/0/2.2077 virtual-circuit-id 2900
root@PE1# set l2circuit neighbor 155.1.1.3 interface ge-0/0/2.2077 no-control-word
root@PE1# set l2circuit neighbor 155.1.1.3 interface ge-0/0/2.2077 encapsulation-type ethernet-vlan
root@PE1# set l2circuit neighbor 155.1.1.3 interface ge-0/0/2.2077 mtu 1500
The configurations are per neighbor and for each VLAN configure a separate interface and interface settings.
     
      5.       Apply commit
root@PE1# commit

PE2 Configuration (Juniper router)
Pretty much the same as PE1

      1.       Make sure router’s loopback is configured under mpls and ldp protocols else configure it:
root@PE2# set protocols mpls interface lo0.0
root@PE2# set protocols ldp interface lo0.0

      2.       Configure the physical ingress router interface for 802.1q tagging for a cross-connect:
root@PE2# set interfaces ge-3/0/0 vlan-tagging
root@PE2# set interfaces ge-3/0/0 encapsulation vlan-ccc

      3.       Configure the appropriate interfaces as units under the physical interface:
root@PE2# set interfaces ge-3/0/0 unit 2900 encapsulation vlan-ccc vlan-id 2900

      4.       Now configure the Layer-2 circuit under protocols:
[edit protocols]
root@PE2# set l2circuit neighbor 155.1.1.1 interface ge-3/0/0.2900 virtual-circuit-id 2900
root@PE2# set l2circuit neighbor 155.1.1.1 interface ge-3/0/0.2900 no-control-word
root@PE2# set l2circuit neighbor 155.1.1.1 interface ge-3/0/0.2900 encapsulation-type ethernet-vlan
root@PE2# set l2circuit neighbor 155.1.1.1 interface ge-3/0/0.2900 mtu 1500 

      5.       Apply commit
root@PE1# commit

PE3 Configuration (Cisco router)
     
      1.       Configure the physical interface:  
interface GigaEthernet2/0
 no ip address
 load-interval 30
 duplex full
end

      2.       Configure the logical interface:
interface GigaEthernet2/0.2077
 encapsulation dot1Q 2077
 xconnect 155.1.1.1 2077 encapsulation mpls
end

      3.       Save the configuration:
Router(config)# wr

Verification

Check Layer-2 link status:
Juniper:
root@PE1> show l2circuit connections extensive
Layer-2 Circuit Connections:

Legend for connection status (St)  
EI -- encapsulation invalid      NP -- interface h/w not present  
MM -- mtu mismatch               Dn -- down                      
EM -- encapsulation mismatch     VC-Dn -- Virtual circuit Down   
CM -- control-word mismatch      Up -- operational               
VM -- vlan id mismatch           CF -- Call admission control failure
OL -- no outgoing label          IB -- TDM incompatible bitrate
NC -- intf encaps not CCC/TCC    TM -- TDM misconfiguration
BK -- Backup Connection          ST -- Standby Connection
CB -- rcvd cell-bundle size bad  SP -- Static Pseudowire
LD -- local site signaled down   RS -- remote site standby
RD -- remote site signaled down  XX -- unknown

Legend for interface status 
Up -- operational           
Dn -- down                  
Neighbor: 155.1.1.2
    Interface                 Type  St     Time last up          # Up trans
    ge-0/0/2.2900(vc 2900)    rmt   Up     Feb 12 03:35:59 2012           1
      Remote PE: 155.1.1.2, Negotiated control-word: No
      Incoming label: 324768, Outgoing label: 319760
      Negotiated PW status TLV: No
      Local interface: ge-0/0/2.2900, Status: Up, Encapsulation: VLAN
    Connection History:
        Feb 12 03:35:59 2012  status update timer 
        Feb 12 03:35:58 2012  PE route changed    
        Feb 12 03:35:58 2012  Out lbl Update                    319760
        Feb 12 03:35:58 2012  In lbl Update                     324768
        Feb 12 03:35:58 2012  loc intf up                ge-0/0/2.2900
Neighbor: 155.1.1.3
    Interface                 Type  St     Time last up          # Up trans
    ge-0/0/2.2077(vc 2077)    rmt   Up     Feb 13 00:34:09 2012           1
      Remote PE: 155.1.1.3, Negotiated control-word: No
      Incoming label: 324752, Outgoing label: 42
      Negotiated PW status TLV: No
      Local interface: ge-0/0/2.2077, Status: Up, Encapsulation: VLAN
    Connection History:
        Feb 13 00:34:09 2012  status update timer 
        Feb 13 00:34:09 2012  PE route changed    
        Feb 13 00:34:09 2012  Out lbl Update                        42
        Feb 13 00:34:09 2012  In lbl Update                     324752
        Feb 13 00:34:09 2012  loc intf up                ge-0/0/2.2077

Cisco:
router#show xconnect all detail
Legend: XC ST=Xconnect State, S1=Segment1 State, S2=Segment2 State
UP=Up, DN=Down, AD=Admin Down, IA=Inactive, NH=No Hardware
XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
UP     ac   Gi2/0.2077 2077(Eth VLAN)    UP mpls 155.1.1.1:2077            UP
            Interworking: none                   Local VC label 42             
                                                 Remote VC label 324752        
                                                 pw-class: