Search This Blog

Monday, May 20, 2013

NAT redundancy between two links



Network topology:


R1 is connected to 2 links: primary and backup
R5 reside in subnet 192.168.15.0/24, R1 will NAT this subnet with the primary interface IP address (10.1.12.1) and in case of fail-over he will switch to the backup link and NAT the network with the backup interface IP address (10.1.13.1).

R1 relevant configuration:

interface FastEthernet0/0
 ip address 192.168.15.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 speed 100
 full-duplex
!
interface FastEthernet0/1
 ip address 10.1.12.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 speed 100
 full-duplex
!
interface FastEthernet1/0
 ip address 10.1.13.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 speed 100
 full-duplex
!
ip route 0.0.0.0 0.0.0.0 10.1.12.2 name DEFAULT_ROUTE
ip route 0.0.0.0 0.0.0.0 10.1.13.3 250 name BACKUP_ROUTE
!
ip nat inside source route-map RM_BACKUP_NAT interface FastEthernet1/0 overload
ip nat inside source route-map RM_PRIMARY_NAT interface FastEthernet0/1 overload
!
ip access-list standard LAN
 permit 192.168.15.0 0.0.0.255
!
route-map RM_PRIMARY_NAT permit 10
 match interface FastEthernet0/1
!
route-map RM_PRIMARY_NAT deny 20
!
route-map RM_BACKUP_NAT permit 10
 match interface FastEthernet1/0
!
route-map RM_BACKUP_NAT deny 20
!

Note that the routing fail-over is done by using static and floating routes, for more accurate and robust solution we will have to use dynamic routing protocol or at least IP-SLA solutions.

R5 ping 192.168.41.1 when the primary link is up:



R5 ping 192.168.41.1 when the primary link is down:


No comments:

Post a Comment